Querying Issues in EU

Incident Report for Honeycomb

Resolved

The issue is now resolved and querying is back to fully functional.
Posted Jun 17, 2026 - 05:32 PDT

Investigating

We are currently investigating the cause of slowness and query failures in our Production EU Region.
Posted Jun 17, 2026 - 05:01 PDT
This incident affected: ui.eu1.honeycomb.io - EU1 Querying.