Activity log delay in production US

Incident Report for Honeycomb

Resolved

All activity log data is now live and up to date.
Posted Apr 10, 2026 - 12:10 PDT

Update

SLO processing has fully recovered.
Posted Apr 09, 2026 - 17:05 PDT

Update

SLOs experienced a period of additional processing delays. A fix has been deployed and recovery is ongoing.
Posted Apr 09, 2026 - 16:43 PDT

Update

We have identified an issue with triggers and SLOs and have implemented a fix. Customers should no longer see degraded performance for triggers or SLOs. A fix for the activity log delay has been implemented and is in the process of recovering. Customers may continue to see activity log unavailability while this completes.
Posted Apr 09, 2026 - 14:03 PDT

Update

We have identified an issue with triggers and SLOs and are actively investigating. Customers may experience delays when creating or updating triggers and SLOs. A fix for the activity log delay has been implemented and is in the process of recovering. Customers may continue to see activity log unavailability while this completes.
Posted Apr 09, 2026 - 13:24 PDT

Identified

We have identified the cause and are working to resolve the issue.
Posted Apr 09, 2026 - 04:52 PDT
This incident affected: ui.honeycomb.io - US1 Trigger & SLO Alerting and ui.honeycomb.io - US1 Activity Log.