We have completed part of our migration. Querying should now be back to normal. Triggers are firing as expected again. SLOs, service maps, and activity log are still delayed and will return to normal gradually.
Posted Dec 16, 2025 - 11:53 PST
Update
Querying should now be back to normal with all historical data. Triggers are firing as expected again. SLOs and service maps are still delayed.
Posted Dec 16, 2025 - 11:43 PST
Update
We are in the middle of the migration, it is expected that new data is unavailable for querying and alerts are slightly delayed.
Posted Dec 16, 2025 - 11:22 PST
Update
As announced earlier, we are now beginning an emergency maintenance procedure. We expect no ingestion downtime, although we will expect delays on processing events and alerts, will suffer minor data loss in our Service Maps feature, and lose roughly 4 days worth of Activity log events (from December 5 to December 9).
Posted Dec 16, 2025 - 10:43 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 16, 2025 - 10:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 15, 2025 - 23:54 PST
Scheduled
As we posted earlier in a previous update, we are going to perform a full evacuation of our old Kafka cluster in the EU region in order to repair the functionality of the Activity Log, among many other internals that are in limp mode currently. This will only impact the EU cluster - we expect no ingestion downtime, although we will expect delays on processing events and alerts, will suffer minor data loss in our Service Maps feature, and lose 11 days worth of Activity log events starting the night of December 5th.
This maintenance will occur at on 6pm UTC December 16th.