Querying slow down in Production US

Incident Report for Honeycomb

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 13:53 PDT

Monitoring

A fix has been implemented and customers should see query speed returning to normal
Posted Jul 21, 2025 - 12:52 PDT

Identified

We are seeing a querying slowdown in the US. We have identified the cause and are working to mitigate
Posted Jul 21, 2025 - 11:01 PDT
This incident affected: ui.honeycomb.io - US1 Querying.