Querying Issues

Incident Report for Honeycomb

Resolved

We have identified the root cause of the intermittent slowness and query failures affecting our Production EU Region. The issue was triggered by a large volume of dataset deletions that caused elevated database load, resulting in query instability. No data was lost during this incident. Service has been restored. A fix has been applied to help prevent recurrence.
Posted Jun 17, 2026 - 14:14 PDT

Monitoring

Querying in our Production EU Region is fully operational. We will continue to monitor for any abnormal behavior.
Posted Jun 17, 2026 - 08:29 PDT

Investigating

We are continuing to investigate intermittent slowness and query failures affecting our Production EU Region. We will provide an update as soon as we have more information.
Posted Jun 17, 2026 - 07:01 PDT
This incident affected: ui.eu1.honeycomb.io - EU1 Querying.