Query Builder WHERE clause rejecting overlapping column names with different casings

Incident Report for Honeycomb

Resolved

The incident has been resolved.
Posted Apr 07, 2025 - 14:22 PDT

Monitoring

A fix has been deployed and we will continue to monitor.
Posted Apr 07, 2025 - 12:58 PDT

Identified

The Query Builder WHERE clause is currently rejecting lower-case selections where there are two columns with the same name that differ only in casing (e.g. if "name" vs "Name" are both present, it would not be possible to select "name"). We have identified the problem and are working on a fix.
Posted Apr 07, 2025 - 12:39 PDT