Triggers intermittently failing in EU region

Incident Report for Honeycomb

Resolved

The degradation in querying and triggers has been resolved and we're back to full functionality.
Posted Jul 28, 2026 - 11:30 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 28, 2026 - 11:21 PDT

Update

The partial degradation has been resolved for all customers except for those specifically contacted. We are working on mitigation measures so that we can fully restore trigger functionality for everyone.
Posted Jul 27, 2026 - 15:51 PDT

Update

We are seeing a regression in performance with partial degradation of both triggers and querying. We are working to remediate.
Posted Jul 27, 2026 - 12:46 PDT

Monitoring

We have identified the source of the issue, applied a temporary fix, and are working on a permanent fix. We continue to monitor the situation.
Posted Jul 27, 2026 - 09:01 PDT

Update

We are continuing to see issues with triggers and are also noticing issues with querying. We are investigating for the cause of both.
Posted Jul 27, 2026 - 06:52 PDT

Investigating

We are seeing triggers intermittently failing in the EU region. We are actively investigating the cause.
Posted Jul 27, 2026 - 06:13 PDT
This incident affected: ui.eu1.honeycomb.io - EU1 Querying and ui.eu1.honeycomb.io - EU1 Trigger & SLO Alerting.