Degraded query performance
Incident Report for Honeycomb
Resolved
The workaround appears to be stable enough, all querying is back to expected performance.
Posted Aug 03, 2022 - 11:51 PDT
Monitoring
We've implemented a workaround and querying capacity should be back to normal. We're keeping an eye on to make sure the fix is solid enough.
Posted Aug 03, 2022 - 11:13 PDT
Identified
We've identified a particularly costly query pattern and we are currently writing a fix to limit its impact. Performance is expected to remain spotty for a while until this is ready. We're exploring alternative mitigation mechanisms at the same time.
Posted Aug 03, 2022 - 10:07 PDT
Investigating
Our query engine is currently under pressure and reporting longer delays to complete queries and more elevated failure rates. We are currently investigating possible sources behind this.
Posted Aug 03, 2022 - 09:48 PDT
This incident affected: ui.honeycomb.io - US1 Querying and ui.honeycomb.io - US1 Trigger & SLO Alerting.