This is an administrative update, marking the incident as Resolved. There has been no further impact since 23:20UTC on May 21 2026.
Posted May 22, 2026 - 09:42 PDT
Update
Impact from this issue has concluded.
For a period of time (different between US and EU instances, noted below), queries spanning data older than the most recent 2 hours with certain GROUP / WHERE clauses returned inconsistent results. Data was never lost, and reruns of the same queries will show the previously missing data.
US impact times: 21:50 UTC - 23:20 UTC EU impact times: 20:50 UTC - 23:20 UTC
Posted May 21, 2026 - 17:49 PDT
Investigating
We have identified and are working to resolve an issue that is causing query results to return inconsistent results.
Posted May 21, 2026 - 16:22 PDT
This incident affected: ui.honeycomb.io - US1 Querying and ui.eu1.honeycomb.io - EU1 Querying.